Zulip Chat Archive

Stream: general

Topic: Lean infoview not working

Hellen Wong (Nov 03 2022 at 14:30):

Hi, my Lean infoview goes blank now, but I can see the result displayed if I hovered my mouse over the code. Screen-Shot-2022-11-03-at-2.29.16-PM.png

Mario Carneiro (Nov 03 2022 at 14:32):

try reloading the window - ctrl-shift-p > "Developer: Reload Window"

Hellen Wong (Nov 03 2022 at 14:36):

It's still not working. And it has an error at the bottom right which says: "Error loading webview: Error: Could not register service workers: InvalidStateError: Failed to register a ServiceWorker: The document is in an invalid state."

Gabriel Ebner (Nov 03 2022 at 18:02):

That's a vscode bug. I think you need to close all vscode windows and then restart it.

Gabriel Ebner (Nov 03 2022 at 18:03):


Gabriel Ebner (Nov 03 2022 at 18:03):

Every couple of months there is a Zulip thread on this.

Hellen Wong (Nov 03 2022 at 22:25):

Hi, I tried to restart VScode, and reload the lean extension multiple times, but it's still not working.

Last updated: Dec 20 2023 at 11:08 UTC