Zulip Chat Archive

Stream: general

Topic: Mac fonts

Jeremy Avigad (Jun 03 2019 at 14:25):

I am teaching a summer school and someone here is having trouble with fonts on the Mac -- when she types "#check 2", the blackboard bold N doesn't appear. Does anyone know how to fix this?

Bryan Gin-ge Chen (Jun 03 2019 at 15:03):

Maybe some of the font recommendations in this thread will work?

Scott Morrison (Jun 03 2019 at 15:04):

Assuming she is using VS Code:
1. Press ⌘, to open preferences.
2. Type font family in the search box.
3. Try changing the defaults to Menlo, Monaco, 'Courier New', monospace.

Jeremy Avigad (Jun 03 2019 at 15:48):

Oh, sorry, I should have been more specific. It is the first day, and she is using the browser javascript version, with Chrome. (But the VS Code information is also helpful!)

Dawn Jiang (Jun 03 2019 at 17:09):

Thanks so much for the instructions! It works now:)

Alexander Bentkamp (Jun 07 2019 at 08:55):

I'am also missing some symbols on Mac, e.g. the subscript "l" in →ₗ[γ]. Has anyone figured out how to get that?

Bryan Gin-ge Chen (Jun 07 2019 at 13:24):

The steps that worked for me (from the thread linked above) were to install the Deja vu fonts and then change the list of fonts in VS code to DejaVu Sans Mono, Menlo, Monaco, 'Courier New', monospace

Chris Hughes (Jun 07 2019 at 13:25):

I use everson mono on mac. You have to download that, but all the unicode characters are monospace, which is nice.

Alexander Bentkamp (Jun 07 2019 at 14:42):

Very cool, thanks!

Last updated: Dec 20 2023 at 11:08 UTC