Zulip Chat Archive

Stream: new members

Topic: unicode fonts for VS code on macOS


view this post on Zulip Bryan Gin-ge Chen (Aug 14 2018 at 23:00):

Does anyone have any recommendations for macOS fonts that include all the unicode symbols in mathlib? On Windows the default fonts seem good so far but there are some missing symbols on macOS like .

view this post on Zulip Edward Ayers (Aug 14 2018 at 23:10):

I'm also interested in font recomendations . On my mac \I and i look exactly the same which lead to some head scratching.

view this post on Zulip Patrick Massot (Aug 14 2018 at 23:12):

Maybe you need OS recommendations :stuck_out_tongue_wink:

view this post on Zulip Gabriel Ebner (Aug 15 2018 at 07:05):

Have you tried the 𝔘𝔫𝔦𝔠𝔬𝔡𝔢 𝔣𝔬𝔫𝔱 𝔰𝔲𝔤𝔤𝔢𝔰𝔱𝔦𝔬𝔫𝔰 for Linux? From what I hear, these fonts run on macOS as well.

Fonts with good unicode support (on Linux): "editor.fontFamily": "Source Code Pro Medium, DejaVu Sans Mono"

view this post on Zulip Sean Leather (Aug 15 2018 at 07:31):

Many of the monospace fonts I've tried on the Mac have a problem with : it takes more than the usual horizontal space, which leads to overlap with other characters. This includes Source Code Pro. I've been using Menlo, which has a good monospace . For some reason, I had not yet tried DejaVu Sans Mono. Now that I have, I see that it's very similar to Menlo. Both also have .

view this post on Zulip Bryan Gin-ge Chen (Aug 15 2018 at 13:06):

Thanks, installing the DejaVu fonts seems to have done the trick! I think Menlo doesn't actually have the character, since it's the default font for VS Code on macOS already (the default setting is "editor.fontFamily": "Menlo, Monaco, 'Courier New', monospace",) and the character wasn't showing up before I installed these fonts. It seems that whenever a font is missing a glyph, the system fills it in from the other installed fonts (if it can).

view this post on Zulip Sean Leather (Aug 15 2018 at 13:12):

Interesting. It seems you're right. I confirmed with Font Book. The Mac symbol viewer only shows the DejaVu fonts under Font Variation for . I previously checked in iTerm2, so, yeah, somebody must be filling in from some other font. I wonder where it's coming from.

view this post on Zulip Oliver Nash (Oct 01 2019 at 20:29):

I realise this thread is old but for the sake of anyone else who has this issue: I just hit the same problem on Mac OS (e.g., no glyph for U+2099) and the same solution worked: installing DejaVu fonts.


Last updated: May 16 2021 at 05:21 UTC